Search found 38 matches

by relistan
14 Sep 2022, 10:13
Forum: Troubleshooting
Topic: No power on transmit (PWR 0.00W)
Replies: 24
Views: 591

Re: No power on transmit (PWR 0.00W)

Yes, I am also surprised. I didn't run high SWR ever: max was 1.5:1. I made about 130 QSOs on it before they died. Both SSB and FT-8. Mine is from the official vendor originally.

What seems to have cooked them was FT-8 on 40m with an SWR 1:1.5. At least that's what was running at the time.
by relistan
13 Sep 2022, 19:13
Forum: Troubleshooting
Topic: No power on transmit (PWR 0.00W)
Replies: 24
Views: 591

Re: No power on transmit (PWR 0.00W)

After to see some details into the forum and measuring the BS170 I discover that the pinout is inverted, so I instaled inverted and works fine! Unfortunatelly the BS170 that I received does not match with the datasheet. Thanks! 73 Ignacio Wow good catch. This us the second time I’ve heard of these ...
by relistan
10 Sep 2022, 16:20
Forum: Troubleshooting
Topic: No power on transmit (PWR 0.00W)
Replies: 24
Views: 591

Re: No power on transmit (PWR 0.00W)

New BS170s were hard to come by in Ireland, but should be here by Friday. For anyone else looking right now, Reichelt in Germany has the correct ones. Sorry, I have to tell you: The Reichelt BS170´s are not on par with original Fairchild / OnSemi. They have measurable different Values..... 73 Manue...
by relistan
10 Sep 2022, 09:30
Forum: Troubleshooting
Topic: No power on transmit (PWR 0.00W)
Replies: 24
Views: 591

Re: No power on transmit (PWR 0.00W)

Have made 8 QSOs on the rig since repair. Working great. Longest at 1368 miles.
by relistan
09 Sep 2022, 14:29
Forum: Troubleshooting
Topic: No power on transmit (PWR 0.00W)
Replies: 24
Views: 591

Re: No power on transmit (PWR 0.00W)

SUCCESS! The ONSemi BS170s arrived today and I took 30 mins to solder them back into the board. IT WORKS. I am seeing somewhat different power and efficiency readings from before, but the radio is working great. Previous BS170s were stamped Fairchild. Power is down slightly, but efficiency is up sl...
by relistan
09 Sep 2022, 12:58
Forum: Troubleshooting
Topic: No power on transmit (PWR 0.00W)
Replies: 24
Views: 591

Re: No power on transmit (PWR 0.00W)

https://www.mouser.de/ProductDetail/onsemi-Fairchild/BS170-D27Z?qs=0lQeLiL1qybtYouixLcZzA%3D%3D 4 in Stock, be fast ;) I have the right ones arriving, hopefully today. Question, though: since the board has a footprint for other FETs (surface mount), would substituting the IRLML2060 work? It seems l...
by relistan
08 Sep 2022, 11:20
Forum: Troubleshooting
Topic: No power on transmit (PWR 0.00W)
Replies: 24
Views: 591

Re: No power on transmit (PWR 0.00W)

Thanks, appreciate your help! I found some ON Semi ones from another source and ordered those. Hopefully that is indeed the problem. We shall see.
by relistan
07 Sep 2022, 17:14
Forum: Troubleshooting
Topic: No power on transmit (PWR 0.00W)
Replies: 24
Views: 591

Re: No power on transmit (PWR 0.00W)

New BS170s were hard to come by in Ireland, but should be here by Friday. For anyone else looking right now, Reichelt in Germany has the correct ones. Sorry, I have to tell you: The Reichelt BS170´s are not on par with original Fairchild / OnSemi. They have measurable different Values..... 73 Manue...
by relistan
07 Sep 2022, 12:07
Forum: Troubleshooting
Topic: No power on transmit (PWR 0.00W)
Replies: 24
Views: 591

Re: No power on transmit (PWR 0.00W)

New BS170s were hard to come by in Ireland, but should be here by Friday. For anyone else looking right now, Reichelt in Germany has the correct ones.
by relistan
05 Sep 2022, 10:20
Forum: Troubleshooting
Topic: No power on transmit (PWR 0.00W)
Replies: 24
Views: 591

Re: No power on transmit (PWR 0.00W)

I guess at this point this thread is for posterity in case it helps someone else out. I am pretty certain now that the problem is just in the PA itself. If I hook up my RSP1a I can see CW transmitted just fine. It's just super low power.
Screen Shot 2022-09-05 at 11.13.47 AM.jpg
Screen Shot 2022-09-05 at 11.13.47 AM.jpg (177.54 KiB) Viewed 465 times
by relistan
04 Sep 2022, 20:29
Forum: Troubleshooting
Topic: No power on transmit (PWR 0.00W)
Replies: 24
Views: 591

Re: No power on transmit (PWR 0.00W)

Well I have new BS170s on the way since I can't really resolder the ones I took out. We will see if that does anything. Maybe they switch on and off, but not fast enough or reliably any more? The DRV signal seems fine as far as I can tell, and so whatever is wrong appears to be on the RF board.
by relistan
04 Sep 2022, 13:14
Forum: Troubleshooting
Topic: No power on transmit (PWR 0.00W)
Replies: 24
Views: 591

Re: No power on transmit (PWR 0.00W)

I reflowed all the joints that seem relevant but nothing changed. I desoldered one of the BS170s for testing and it seems to test fine as far as I can tell.

EDIT: did the same for the other two, and they also test fine (multimeter diode mode test)
by relistan
04 Sep 2022, 09:22
Forum: Troubleshooting
Topic: No power on transmit (PWR 0.00W)
Replies: 24
Views: 591

Re: No power on transmit (PWR 0.00W)

Anyone know anything here?
by relistan
02 Sep 2022, 22:16
Forum: Troubleshooting
Topic: new problem with my (tr)uSDX
Replies: 6
Views: 292

Re: new problem with my (tr)uSDX

Sounds like a short, possibly on the solder work you did. Double check your pinouts and also that you did not bridge any solder joints.
by relistan
02 Sep 2022, 17:27
Forum: Troubleshooting
Topic: Tx not working anymore after 12v bad plug in
Replies: 11
Views: 471

Re: Tx not working anymore after 12v bad plug in

You could also have killed the RX/TX switch BS170 (SMD on the pcb). Sorry Chris, but I cannot find any RX/TX switch on the DLSMAN schematics This radio technology is new for me, so I can only try to understand through the DL2MAN schematics. I am also debugging power issues on my rig on another thre...
by relistan
02 Sep 2022, 13:27
Forum: Troubleshooting
Topic: No power on transmit (PWR 0.00W)
Replies: 24
Views: 591

Re: No power on transmit (PWR 0.00W)

Measuring with the multimeter on the RF board, I see that DRV is high at 4.57v when running from USB power. When I am in CW mode and press PTT, DRV drops to about 2.5v. That seems to me to indicate that it is passing out from the main board down into the RF board. But, when I measure the voltage acr...
by relistan
02 Sep 2022, 06:47
Forum: Troubleshooting
Topic: No power on transmit (PWR 0.00W)
Replies: 24
Views: 591

Re: PWR 0.00W and SWR is nan %

I can hear a signal coming out of the rig when listening on my SDR with a tiny little antenna attached. So it's not totally borked. I will try to figure out how to test/measure the FETs in circuit EDIT: I only have a multimeter to test with, but in testing with that, the mosfets all have a voltage d...
by relistan
01 Sep 2022, 20:47
Forum: Troubleshooting
Topic: No power on transmit (PWR 0.00W)
Replies: 24
Views: 591

Re: PWR 0.00W and SWR is nan %

Inspecting the FETs, they don't look obviously burnt from the outside. Radio was working great beforehand
IMG_8915.jpg
IMG_8915.jpg (249.05 KiB) Viewed 586 times
by relistan
01 Sep 2022, 20:12
Forum: Troubleshooting
Topic: No power on transmit (PWR 0.00W)
Replies: 24
Views: 591

No power on transmit (PWR 0.00W)

I am not sure what happened and am looking for advice. Is my rig blown? Receive works completely fine, but I don't seem to be able transmit. When checking SWR (in the display, don't have an external meter) on my 40m antenna, I see power of 0.00W and an SWR of nan % indicating a divide by 0. That see...
by relistan
29 Aug 2022, 19:10
Forum: General Information
Topic: Anyone using AliExpress 45w/70w linear amp
Replies: 11
Views: 571

Re: Anyone using AliExpress 45w/70w linear amp

KA6VPJ thanks for the info! Been looking at this also and was wondering about where to get a filter that works with it.

Cheers
by relistan
26 Jul 2022, 08:57
Forum: Troubleshooting
Topic: Fix for Hamlib and WSJT-X on macOS
Replies: 2
Views: 164

Re: Fix for Hamlib and WSJT-X on macOS

Excellent, thanks Guido!
by relistan
25 Jul 2022, 14:02
Forum: Troubleshooting
Topic: Fix for Hamlib and WSJT-X on macOS
Replies: 2
Views: 164

Fix for Hamlib and WSJT-X on macOS

After some info on another thread from Guido about how to make Hamlib work on Linux, I was also able to get it running on macOS. I wrote a little shell script and README on how to make that work. You can find it here: https://gist.github.com/relistan/bd9c4b8bab55b81c0374f30bf565bbe0 Hope it helps so...
by relistan
22 Jul 2022, 17:20
Forum: Troubleshooting
Topic: Hamlib error: Protocol error
Replies: 14
Views: 1282

Re: Hamlib error: Protocol error

I suspect the above will work the same for the issue Guido mentioned on Linux as well. I have not tested that.
by relistan
22 Jul 2022, 16:54
Forum: Troubleshooting
Topic: Hamlib error: Protocol error
Replies: 14
Views: 1282

Hamlib Working SOLUTION for macOS

Thanks to Guido for putting me on the right track. I have a simple solution that works for Hamlib on macOS. You will run `rigctld` itself rather than letting WSJT-X do it. Find your serial port (This will be something like /dev/tty.usbserial-141410): ls -ltar /dev/ | tail Then run this, using *your ...