Some expected CAT commands are not working.

Post Reply
RichardB
 

Posts: 12
Joined: 15 May 2022, 01:37

Some expected CAT commands are not working.

Post by RichardB »

I got the (tr)uSDX radio because a friend of mine had one. I have had a few issues with the radio. Have reloaded the bootloader and then the firmware, both from DL2MAN website. Was successful.

Working with WSJT-X, I found that some things were not working like they do with my IC-7300. Things like setting the bandwidth. Studied the WSJT-X and how CAT control works (without using flrig). In the forum, it was stated that (tr)uSDX supports all TS-480 CAT commands. So I got a manual for the TS-480 and started to explore the CAT commands. Using PUTTY, I went thru the commands and found that many of them did not work. Makes sense to a degree because the (tr)uSDX doesn't have all the features of the TS-480. But some commands like bandwidth and a few others should work as (tr)uSDX has those features. Farther, I found that the radio seems to lock up on some of the commands. This is especially true if the radio is in CW mode. Some commands produced strange responses. Found that changing the mode using the MD command produced some really interesting results - especially when sending 'MD6;' or 'MD7;' which are unsupported modes in the (tr)uSDX. Sending and 'MD3;', which is the CW mode, will switch (tr)uSDX results in this: switched to CW mode, indicates 'T' that it is transmitting and locks up the radio.

Has anyone else seen this?
Post Reply