Feedback thread for Firmware 2.00t BETA

DL2MAN
 

Posts: 710
Joined: 30 Dec 2021, 19:18
Contact:

Feedback thread for Firmware 2.00t BETA

Post by DL2MAN »

New Beta Firmware available here:
https://dl2man.de/wp-content/uploads/20 ... /beta.html
Please try out the new features and give us feedback.
Explaination Video here:
https://youtu.be/N-egrMMcIrA

73 Manuel; DL2MAN & Guido, PE1NNZ
KK4DF
 

Posts: 7
Joined: 03 Sep 2022, 20:41

Re: Feedback thread for Firmware 2.00t BETA

Post by KK4DF »

Manuel and Guido,

The beta seems to be working pretty well, and I do love the new spectrum display capability! I will have to also take time to use the extra CW memories, which I had not used before due to there being only one, previously.

One thing I notice is that after using the spectrum display, my callsign is missing when I release the Menu button. I can easily get just by entering and exiting the menu system one time.

Walt - KK4DF
elTrauko
 

Posts: 31
Joined: 04 Jan 2022, 21:58

Re: Feedback thread for Firmware 2.00t BETA

Post by elTrauko »

It doesn't work on my (tr)USDX, it stays stuck showing the photo screen.
I tried to go back to the previous FW and it doesn't work, it's still stuck
I have a brick now?
Third try and I get it back with FW 2.00m :D

I install the new FW on my spare (tr)USDX and it works perfect. I don't know what could be different, they are both classic bands.

Hermoso...
Gracias Manuel y Guido
Last edited by elTrauko on 06 Mar 2023, 00:33, edited 1 time in total.
KK4DF
 

Posts: 7
Joined: 03 Sep 2022, 20:41

Re: Feedback thread for Firmware 2.00t BETA

Post by KK4DF »

I had a similar screen, showing the serial number, when I put the firmware from a “different” serial number. I have two truSDX units, and I put the firmware for the wrong S/N into the radio first. Once I put the firmware downloaded for the correct S/N (as shown on the screen you uploaded), it worked as it should.

Good luck,
Walt - KK4DF
Jürgen_1212
 

Posts: 1
Joined: 23 Jan 2023, 17:30

Re: Feedback thread for Firmware 2.00t BETA

Post by Jürgen_1212 »

Hello Guido,

you made a greate task by implementing the realtime spectrum on the 8bit controller. Many congratulations and thank you very much.

While Manuel presented the new spectrum feature I thought about how to use the spectrum in a ham operation scenario.

The VFO is tuned to a certain frequency. Now the OM wants to know whether other stations are busy on a lower or higher frequency. Therefore, he presses the button as shown in the video by Manuel. In this situation the audio is muted due to the 8bit controller performance and the spectrum is viewed in realtime.

My proposal: freeze the spectrum on the display within e.g. half a second and unmute the audio again. Turning the knob will change the VFO up or down and the OM can listen to the audio. A marker below the spectrum moves left or right accordingly on the display. If the OM releases the button the spectrum disappears.

The advantages (from my point of view) are:
a) the OM gets a spectrum view snapshot;
b) the OM can listen to the audio for fine tuning;
c) a marker below the snapshot moves according to the VFO tuning;
d) if the upper or lower edge of the display is reached a new spectrum snapshot is done automatically by the firmware.

What do you think about my idea?
dl6sez
 

Posts: 399
Joined: 30 Dec 2021, 22:54

Re: Feedback thread for Firmware 2.00t BETA

Post by dl6sez »

Hello Jürgen,

this will be nearly useless for CW signals....

73 de Chris
Chris DL6SEZ, JN48XL near Ulm, Southern Germany
elTrauko
 

Posts: 31
Joined: 04 Jan 2022, 21:58

Re: Feedback thread for Firmware 2.00t BETA

Post by elTrauko »

KK4DF wrote: 05 Mar 2023, 20:14 I had a similar screen, showing the serial number, when I put the firmware from a “different” serial number. I have two truSDX units, and I put the firmware for the wrong S/N into the radio first. Once I put the firmware downloaded for the correct S/N (as shown on the screen you uploaded), it worked as it should.

Good luck,
Walt - KK4DF
Thanks, that was the problem, I have 3 (tr), 2 classic bands and 1 low band for use in 30m. Lesson: write down the serial number on each team.

Thanks, Walt.
Attachments
WhatsApp Image 2023-03-05 at 19.03.49.jpeg
WhatsApp Image 2023-03-05 at 19.03.49.jpeg (71.26 KiB) Viewed 11183 times
User avatar
ve2rn
 

Posts: 55
Joined: 13 Jan 2022, 20:45

Re: Feedback thread for Firmware 2.00t BETA

Post by ve2rn »

I have tried WSJTX after firmware update and the cat com speed is now 115200 but
the rest is ok on my side
Sylvain Naud
VE2RN
N6WLM
 

Posts: 20
Joined: 12 Jul 2022, 03:15

Re: Feedback thread for Firmware 2.00t BETA

Post by N6WLM »

The spectrum feature works great on my rig. Amazing work, love it!
Cthulhu
 

Posts: 12
Joined: 30 Dec 2022, 16:53

Re: Feedback thread for Firmware 2.00t BETA

Post by Cthulhu »

Very buggy. The sound disappears completely. The screen does not draw after exiting the menu. VOX does not work. Sadly. Rolling back to the stable version
wb9oqb
 

Posts: 7
Joined: 18 Sep 2022, 23:33

Re: Feedback thread for Firmware 2.00t BETA

Post by wb9oqb »

It seems to be working good on both my classic and low band rigs.
The spectrum feature makes it easier to find a clear spot to call CQ, and having the extra cw memories is nice as well.
Sure is a fun little kit.
gatorjj
 

Posts: 50
Joined: 11 Oct 2022, 00:06

Re: Feedback thread for Firmware 2.00t BETA

Post by gatorjj »

Took my classic band out for a couple hours of POTA today with the new firmware. The new features are awesome! Moving the tuner back as well as forward (digit-wize) sure makes switching between CW and SSB a lot easier. The CW memory worked great as well.

Only issue I can point to, maybe, is occasionally hitting "menu" twice to kick off the CW message would bring the spectrum display up for a second and leave a largely blank screen. Pressing "menu" again would fix it and kick off the message. Not sure if it was my timing on the button or the ATMega getting overloaded, in any case it didn't cause any issue...just one more press and off it went.

FYI I crossed 1,000 (tr)usdx QSO's today, the new firmware is a great gift :D
la3fy
 

Posts: 2
Joined: 17 Feb 2023, 20:37

Re: Feedback thread for Firmware 2.00t BETA

Post by la3fy »

There are bugs as reported in other posts. I have seen a screen with a lot of hex numbers showing up at the first lien. I have also seen a letter "E" showing up between USB/LSB/CW indication and the R/T. Some times the rig is freezing and I need powering up again.
Karl
Ea1fof
 

Posts: 10
Joined: 17 Feb 2023, 20:55

Re: Feedback thread for Firmware 2.00t BETA

Post by Ea1fof »

since internal memory was released by eliminating the fm and am, the spect is fine but it would be more useful for me if the roe meter worked in ssb
73 de EA1FOF
gatorjj
 

Posts: 50
Joined: 11 Oct 2022, 00:06

Re: Feedback thread for Firmware 2.00t BETA

Post by gatorjj »

gatorjj wrote: 06 Mar 2023, 23:37 Only issue I can point to, maybe, is occasionally hitting "menu" twice to kick off the CW message would bring the spectrum display up for a second and leave a largely blank screen. Pressing "menu" again would fix it and kick off the message.
I learned from the facebook group that this is a "feature" and not a bug...and a feature that is very nice on 15m and 10m! :lol:

I've been trying, but have yet to run into any actual issues. Seems pretty solid :D
dh6pn
 

Posts: 3
Joined: 04 Apr 2022, 09:36

Re: Feedback thread for Firmware 2.00t BETA

Post by dh6pn »

Beta Firmware 2.00t Super good
73!
dh6pn
 

Posts: 3
Joined: 04 Apr 2022, 09:36

Re: Feedback thread for Firmware 2.00t BETA

Post by dh6pn »

IN3VXH
 

Posts: 4
Joined: 10 Nov 2022, 08:35

Re: Feedback thread for Firmware 2.00t BETA

Post by IN3VXH »

Hi guys,
It's really amazing what you are doing on a device like that....
From my side a strange issue came out after the Beta firmware has been installed:
when pushing the encoder in order to change the volume level the rtx moves up the frequency step.
No other bad behaviors so far but I'm going to reinstall the older version.
73 Luca
YS1RS
 

Posts: 12
Joined: 09 Jul 2022, 01:44

Re: Feedback thread for Firmware 2.00t BETA

Post by YS1RS »

My report was sent as a comment to the video. I am saving it here to keep feedback on one single place, as requested by Manuel, DL2MAN. Thanks!

Amazing!!! I am using it now. Works perfectly!!!
No problem if FM/AM is not there anymore. Well, at least for me.

Something I have to report is that, with the old firmware, I was able to shut down the radio by lowering down the volume to zero (null). But now this no longer works. The radio goes down to zero and then to volume -1 but does not shut down.
Apart from that no issues. Ahh yes, for digital, you have to use 115200 baud rate and then it works (this was mentioned in the video).
I use Ham Radio Deluxe with the following settings (in case someone finds it useful)...
Company: Kenwood
Radio: TS-480, Com Port : COM7 (in my case, yours will be different)
Speed: 115200
RTS ON and nothing else.

Recommendation:
I make sure, before connecting to the (tr)uSDX, in case I have been using the computer connected to another radio before, I restart the computer. The fresh start, makes sure it will work well and will connect to the (tr)uSDX with no issues.

Update from DL2MAN. He replied to my comment above, regarding the switching off by bringing the volume down to zero, which is no longer available in this new firmware release...:
"That was a useless feature anyway, as it would still consume power in the "off" state."

73
Rob
YS1RS
K3RTA
 

Posts: 24
Joined: 29 Oct 2022, 21:32

Re: Feedback thread for Firmware 2.00t BETA

Post by K3RTA »

OK, I've followed the directions exactly per the use of AVRDUDESS software to upload my specific firmware (2.00 beta) to my (tr)uSDX.


[Very heavy snip of long material]


[Edit] I thought I had an upload problem but do not have the problem I thought I had. I needed to download the file from Manuel's YouTube address, and that worked really well. I plan to try this Beta out in the field today.


Tnx,

K3RTA
Last edited by K3RTA on 12 Mar 2023, 13:34, edited 1 time in total.
2w0xhd
 

Posts: 2
Joined: 24 Feb 2023, 11:26

Re: Feedback thread for Firmware 2.00t BETA

Post by 2w0xhd »

I have only found 2 small bugs https://youtube.com/shorts/9AEUBoKDlFA?feature=share

The screen going blank could be good for reducing noise but I don't hear much difference on my lo band version.
VE3RRD
 

Posts: 56
Joined: 31 Dec 2021, 14:59

Re: Feedback thread for Firmware 2.00t BETA

Post by VE3RRD »

The bootloader was optimized recently to make it more compact and save memory usage. Since the latest Beta firmware releases utilize all available memory, is it necessary for anyone with the older larger bootloader on their (tr)uSDX to upgrade it before loading the newest firmware?
chancekp
 

Posts: 3
Joined: 15 Feb 2023, 21:03

Re: Feedback thread for Firmware 2.00t BETA

Post by chancekp »

I love the scope and everything seems to work fine on SSB. Even after adjusting WSJT-X baud rate to 115,200 I still can't get CAT control to work. Regardless of the baud rate I choose I get the same error. Anyone else overcome this problem?
ke4rg
 

Posts: 1
Joined: 25 Feb 2023, 03:13

Re: Feedback thread for Firmware 2.00t BETA

Post by ke4rg »

Power On screen is now garbled! CW Tx power now zero, SWR 1.0! Reverted to previous, still no TX power. All else works great. Any suggestions?
ke4rg
K4KPG
 

Posts: 2
Joined: 21 Mar 2023, 16:57

Re: Feedback thread for Firmware 2.00t BETA

Post by K4KPG »

Thanks for the beta to test.

It worked fine on my Standard unit but changed the bands on my Classic unit to the standard bands.

Even reinstalling the original firmware did not bring back the Classic bands.

Is there a way to get back the Classic Bands?
Mark K4KPG
Post Reply

Users browsing this forum: No registered users and 3 guests